构建gem5

这里记录一下构建 InvisiSpec 的 gem5 模拟器的过程。

由于 InvisiSpec 的作者只上传了代码,没有 gem5 的历史记录,所以看不出是基于哪个版本的 gem5 做的。我尝试了几个系统,最后使用的是 Ubuntu 16.04.5.

安装依赖,大致是这些吧:

apt install scons python-dev libprotobuf-dev protobuf-compiler python-pydot zlib1g-dev m4 libgoogle-perftools-dev

然后构建,看了 InvisiSpec 的样例脚本之后,才知道要构建什么:

scons -j$(nproc) build/X86_MESI_Two_Level/gem5.fast